Arbitrage(poj 2240) bellman_ford

Arbitrage

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 26198 Accepted: 11040

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 

Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format “Case case: Yes” respectively “Case case: No”.

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No
#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <map>

using namespace std;

map<string,int> maps;
int n,m;
int u[1000],w[1000];
float v[1000];
float dis[35];
int count;

int main()
{
    while(cin>>n){
        count++;
        if(n==0)
            break;
        for(int i=1;i<=n;i++){
            string s;
            cin>>s;
            maps[s]=i;
        }
        cin>>m;
        string s1,s2;
        float num;
        for(int i=1;i<=m;i++){
            cin>>s1>>num>>s2;
            u[i]=maps[s1],w[i]=maps[s2];
            v[i]=num;
        }
        bool flag=0;
        memset(dis,0,sizeof(dis));
        dis[1]=1;
        for(int k=1;k<=n;k++){
            for(int i=1;i<=m;i++){
                if(dis[w[i]]<dis[u[i]]*v[i]){
                    dis[w[i]]=dis[u[i]]*v[i];
                    //cout<<u[i]<<' '<<dis[u[i]]<<' '<<v[i]<<endl;
                    //cout<<w[i]<<' '<<dis[w[i]]<<endl;
                }
            }
        }
        for(int i=1;i<=m;i++){
            if(dis[w[i]]<dis[u[i]]*v[i]){
                flag=1;
                break;
            }
        }
        if(flag)
            cout<<"Case "<<count<<": "<<"Yes"<<endl;
        else
            cout<<"Case "<<count<<": "<<"No"<<endl;
    }
}

    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/qq_38665638/article/details/79914863
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞