Poj1860 Currency Exchange Bellman-Ford

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 

For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 – 0.39) * 29.75 = 2963.3975RUR. 

You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B – numbers of currencies it exchanges, and real R
AB, C
AB, R
BA and C
BA – exchange rates and commissions when exchanging A to B and B to A respectively. 

Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N – the number of currencies, M – the number of exchange points, S – the number of currency Nick has and V – the quantity of currency units he has. The following M lines contain 6 numbers each – the description of the corresponding exchange point – in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10
3

For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10
-2<=rate<=10
2, 0<=commission<=10
2

Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10
4

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

Source

Northeastern Europe 2001, Northern Subregion

思路:

根据题目输入的各个种类的钱之间的关系构造一张图。

求回到初始种类时钱能否增加,就是求该图中有没有正权回路。

已知Bellman-Ford算法可以求负权回路,那么改一下就可以求正权回路了。


具体实现:

先跑一变最长路径;

for(int i=1; i<=n; i++) {
 for(int j=0; j<2*m; j++) {
		if(b[e[j].x]&&!b[e[j].y]) {
			dis[e[j].y]=max(dis[e[j].y],(dis[e[j].x]-e[j].com)*e[j].rate);
		}
	}
	int big=-1,bignum=0;
	for(int i=1; i<=n; i++) {
		if(!b[i]&&dis[i]>big) {
			bignum=i;
			big=dis[i];
		}
	}
	b[bignum]=true;
}

如果没有正权回路,那么求出来的就是最长路径。但是如果还可以通过某一个点x把点dis[y]更新的更小,那么一定存在正权回路。

for(int j=0; j<2*m; j++) {
	if(dis[e[j].y]<(dis[e[j].x]-e[j].com)*e[j].rate) {
		return true;
	}
}

代码:

#include<cstdio>
#include<iostream>
#include<vector>
using namespace std;

int n,m;
int startnum;
double startmoney;

struct Edge {
	int x,y;
	double rate,com;
	Edge() {}
	Edge(int xx,int yy,double rr,double cc) {
		x=xx,y=yy,rate=rr,com=cc;
	}
};

vector<Edge> e;

bool bellman() {

	bool b[105]= {0};
	double dis[105]= {0};
	b[startnum]=true;
	dis[startnum]=startmoney;

	for(int i=1; i<=n; i++) {
		for(int j=0; j<2*m; j++) {
			if(b[e[j].x]&&!b[e[j].y]) {
				dis[e[j].y]=max(dis[e[j].y],(dis[e[j].x]-e[j].com)*e[j].rate);
			}
		}
		int big=-1,bignum=0;
		for(int i=1; i<=n; i++) {
			if(!b[i]&&dis[i]>big) {
				bignum=i;
				big=dis[i];
			}
		}
		b[bignum]=true;
	}

	for(int j=0; j<2*m; j++) {
		if(dis[e[j].y]<(dis[e[j].x]-e[j].com)*e[j].rate) {
			return true;
		}
	}

	return false;

}

int main() {

	scanf("%d%d%d%lf",&n,&m,&startnum,&startmoney);
	for(int i=1; i<=m; i++) {
		int x,y;
		scanf("%d%d",&x,&y);
		double r,c;
		scanf("%lf%lf",&r,&c);
		e.push_back(Edge(x,y,r,c));
		scanf("%lf%lf",&r,&c);
		e.push_back(Edge(y,x,r,c));
	}

	if(bellman()) {
		printf("YES");
	} else {
		printf("NO");
	}

	return 0;
}


    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/rabbit_ZAR/article/details/63253225
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞