【bellman_ford】poj2240

 Arbitrage

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 

Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format “Case case: Yes” respectively “Case case: No”.

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No
哭死
<pre class="sio" style="font: 14px/26px 'Courier New', Courier, monospace; text-align: left; color: rgb(54, 46, 43); text-transform: none; text-indent: 0px; letter-spacing: normal; word-spacing: 0px; white-space: pre-wrap; -ms-word-wrap: break-word; background-color: rgb(255, 255, 255); -webkit-text-stroke-width: 0px;" name="code">题目大意:告诉各种钱币之间的汇率,问是否可以通过若干次兑换似的钱变多
每种可以兑换的钱币之间连一条边,用bellman_ford可以求出有无权值相乘大于1的环
字符串与点之间的映射用map实现(话说我又差点自己想怎么一一对应,然后反应过来c++里有map ,o(╯□╰)o)
<pre class="cpp" name="code">#include<iostream>
#include<cstring>
#include<cstdio>
#include<map>
#include<algorithm>
using namespace std;
struct ty
{
    long s, t;
    double w;
};
map <string, int> q;
long n, m;
ty edge[1010];
double dist[1010];
void insertedge(long x, long y, double z, long k)
{
    //cout << x << ' ' << y<< ' ' << z <<endl;
    edge[k].s = x;
    edge[k].t = y;
    edge[k].w = z;
}
void init()
{
    q.clear();
    long t=0;
    char s1[100], s2[100];
    for(long i = 0; i < n; i++)
    {
        scanf("%s", s1);
        if(q[s1] == 0)
            q[s1] = ++t;
    }
    scanf("%d", &m);
    for(int i = 1; i <= m; i++)
    {
        double w;
        scanf("%s%lf%s", s1, &w, s2);
        insertedge(q[s1], q[s2], w, i);
    }
}

bool bellman_ford(long u)
{
    memset(dist, 0, sizeof(dist));
    dist[u] = 1;
    for(long i = 1; i <= n; i++)
    {
        for(long j = 1; j <= m; j++)
        {

            long s = edge[j].s,t = edge[j].t;
            double w = edge[j].w;
            if(dist[s] * w > dist[t]) dist[t] = dist[s] * w;
           // cout << dist[s] << ' ' << dist[t] << ' ' << t <<endl;
        }
    }
   // cout << dist[u] - 1<< endl;
    if(dist[u] > 1.0) return true;
    return false;
}
int main()
{
    freopen("poj2240.in", "r", stdin);
    long  k = 0;
    while (scanf("%d",&n), n != 0)
    {
        k++;
        init();
        //cout << n << ' ' << m<<endl;
        bool b = false;
        for(long i = 1;i <= n;i++)
        {
            if (bellman_ford(i))
            {
                b = true;
                break;
            }
        }
        if(b) printf("Case %d: Yes\n", k);
        else printf("Case %d: No\n", k);
    }
    return 0;
}

    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/u013006746/article/details/39835257
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞