POJ1860 Currency Exchange(Bellman-ford的变形)

Currency Exchange

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 21433 Accepted: 7680

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.

For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 – 0.39) * 29.75 = 2963.3975RUR.

You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B – numbers of currencies it exchanges, and real R
AB, C
AB, R
BA and C
BA – exchange rates and commissions when exchanging A to B and B to A respectively.

Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.

Input

The first line of the input contains four numbers: N – the number of currencies, M – the number of exchange points, S – the number of currency Nick has and V – the quantity of currency units he has. The following M lines contain 6 numbers each – the description of the corresponding exchange point – in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10
3.

For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10
-2<=rate<=10
2, 0<=commission<=10
2.

Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10
4.

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

解题思路:

本题是“求最大路径”,之所以被归类为“求最小路径”是因为本题题恰恰与bellman-Ford算法的松弛条件相反,求的是能无限松弛的最大正权路径,但是依然能够利用bellman-Ford的思想去解题。因此初始化d(S)=V   而源点到其他店的距离(权值)初始化为无穷小(0),当s到其他某点的距离能不断变大时,说明存在最大路径。

代码:

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;

const int maxn = 102;

int n; //货币总数
int m; //兑换方式总数
int s; //有第s种货币
double v; //有该种的本金数

int cnt; //边总数
double dis[maxn]; //s到各点的权值

struct exchange
{
    int a;  //货币a
    int b;  //货币b
    double r; //rate
    double c; //手续费
}exc[2*maxn];

bool bellman()
{
    memset(dis,0,sizeof(dis));  //求最大正环,所以初始都为0,bellman-ford负环初始为无穷大
    dis[s] = v; //表示持有s种货币v个
    int i,j;
    bool flag;
    for(i=1;i<n;i++)
    {
        flag = false;
        for(j=0;j<cnt;j++)
        {
            if(dis[exc[j].b] < (dis[exc[j].a] - exc[j].c) * exc[j].r)
            {
                dis[exc[j].b] = (dis[exc[j].a] - exc[j].c) * exc[j].r;
                flag = true;
            }
        }
        if(!flag)
        {
            break;
        }
    }
    for(i=0;i<cnt;i++)
    {
        if(dis[exc[i].b] < (dis[exc[i].a] - exc[i].c) * exc[i].r)
        {
            return true;
        }
    }
    return false;
}

int main()
{
    int i;
    int a,b;
    double rab,cab,rba,cba;
    //freopen("111","r",stdin);
    while(cin>>n>>m>>s>>v)
    {
        cnt = 0;
        for(i=0;i<m;i++)
        {
            cin>>a>>b>>rab>>cab>>rba>>cba;  //双向边
            exc[cnt].a = a;
            exc[cnt].b = b;
            exc[cnt].r = rab;
            exc[cnt++].c = cab;
            exc[cnt].a = b;
            exc[cnt].b = a;
            exc[cnt].r = rba;
            exc[cnt++].c = cba;
        }
        if(bellman())
        {
            cout<<"YES"<<endl;
        }
        else
        {
            cout<<"NO"<<endl;
        }
    }
    return 0;
}

    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/u013021513/article/details/44275305
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞