poj1860之Bellman-Ford解法

Currency Exchange
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 31398 Accepted: 11916
Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 – 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B – numbers of currencies it exchanges, and real RAB, CAB, RBA and CBA – exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.
Input

The first line of the input contains four numbers: N – the number of currencies, M – the number of exchange points, S – the number of currency Nick has and V – the quantity of currency units he has. The following M lines contain 6 numbers each – the description of the corresponding exchange point – in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 104.
Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.
Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00
Sample Output

YES

题意:输入n种货币,m种货币转换关系,Nick拥有的第s种货币和货币量,求能否通过投机倒把,货币转换将货币变多
分析:把n种货币看成是n个节点,每种转换看成一条边,重点是求图中是否存在回路.我们知道Bellman-Ford算法可以在DAG条件下可以求到每个点的最短路径.假设此题中不存在正权回路,那么我们可以借用Bellman-Ford求到每个点的最大路径,如果循环次数超过理论上的最大值,说明存在了正权回路(由于正权回路的存在,使得最大路径可以不断更新)

//上述分析可能有点不好理解,我们先看一些基础知识点

  • Bellman-Ford算法
 设从起点s出发到定点i的最短距离为d[i],则有

 d[i] = min(d[j]+cost(j->i))//j为其他顶点
 如果给定的图是一个没有圈的有向图DAG,那么我们在给顶点编号之后,就可以不断使用递推关系更新d的值

 struct edge{int from,to,cost};
 edge es[MAX_E];//边
 int dis[MAX_V];//最短距离
 int V,E;//V是vertex顶点,E是edge边

 void shortest_path(int s)
 {
    for (int i = 0; i < v; i += 1) dis[i] = INF;
    dis[s] = 0;
    while (true){
        bool flag = false;
        for (int i = 0; i < E; i += 1){
            edge e = es[i];
            if (dis[e.to] > dis[e.from] + e.cost){
                dis[e.to] = dis[e.from] + e.cost;
                flag = true;
            }
        }
        if (!flag) break;
    }
 }

分析:内层循环遍历每条边,假设没有负圈,那么推进的过程中,不会经过一个节点两次.把整个算法的遍历过程和广搜联系起来,你会发现每次内层循环都会往前推进一层节点.由于最多有V-1层,因此while最多有V-1次.所以复杂度是O(V*E)

如果有负圈,那么外层遍历一定会超过V-1,因此可以用来判断是否有负圈

bool find_negative_loop()
{
    memset(d,0,sizeof(d));
    for (int i = 0; i < V; i += 1){
        for (int j = 0; j < E; j += 1){
            edge e = es[ij;
            if (dis[e.to] > dis[e.from] + e.cost){
                dis[e.to] = dis[e.from] + e.cost;
                //如果不存在负圈,V-1次已经更新完毕,第V次不应该更新
                if (i == V-1) return true;
            }
        }
    }
    return false;
}

解题代码
《poj1860之Bellman-Ford解法》

#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <stack>
#include <queue>
#include <algorithm>
#include <cstring>
#include <string>
#include <cmath>
#include <vector>
#include <bitset>
#include <list>
#include <sstream>
#include <set>
#include <functional>
using namespace std;

int n,m,s;//n为节点数
double v;
int k = 0;//k为边数
double dis[105];


struct change {
    int from;
    int to;
    double r;
    double c;
};
change ch[205];

void solve()
{
    memset(dis,0,sizeof(dis[0]));
    dis[s] = v;
    for (int i = 0; i < n; i += 1){
        for (int j = 0; j < k; j += 1){
            change ed = ch[j];
            if (dis[ed.to] < (dis[ed.from] - ed.c)*ed.r){
                dis[ed.to] = (dis[ed.from] - ed.c)*ed.r;
                if (i == n-1){
                    printf("YES\n");
                    return;
                }
            }
        }
    }
    printf("NO\n");
}

int main()
{
    int a,b;
    scanf("%d%d%d%lf",&n,&m,&s,&v);
    for (int i = 0; i < m; i += 1){
        cin >> a >> b;
        ch[k].from = a;
        ch[k].to = b;
        cin >> ch[k].r >> ch[k].c;
        ch[++k].from = b;
        ch[k].to = a;
        cin >> ch[k].r >> ch[k].c;
        k++;
    }
    solve();
    return 0;
}
    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/xxiaobaib/article/details/76997487
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞