AOJ GRL_1_C: All Pairs Shortest Path (Floyd-Warshall算法求任意两点间的最短路径)(Bellman-Ford算法判断负圈)

题目链接:http://judge.u-aizu.ac.jp/onlinejudge/description.jsp?id=GRL_1_C

All Pairs Shortest Path

Input
An edge-weighted graph G (V, E).

|V| |E|
s0 t0 d0
s1 t1 d1
:
s|E|−1 t|E|−1 d|E|−1
|V| is the number of vertices and |E| is the number of edges in G. The graph vertices are named with the numbers 0, 1,…, |V|−1 respectively.

si and ti represent source and target vertices of i-th edge (directed) and di represents the cost of the i-th edge.

Output
If the graph contains a negative cycle (a cycle whose sum of edge costs is a negative value), print

NEGATIVE CYCLE
in a line.

Otherwise, print

D0,0 D0,1 … D0,|V|−1
D1,0 D1,1 … D1,|V|−1
:
D|V|−1,0 D1,1 … D|V|−1,|V|−1
The output consists of |V| lines. For each ith line, print the cost of the shortest path from vertex i to each vertex j (j=0,1,…|V|−1) respectively. If there is no path from vertex i to vertex j, print “INF”. Print a space between the costs.

Constraints
1 ≤ |V| ≤ 100
0 ≤ |E| ≤ 9900
-2 × 107 ≤ di ≤ 2 × 107
There are no parallel edges
There are no self-loops
Sample Input 1
4 6
0 1 1
0 2 5
1 2 2
1 3 4
2 3 1
3 2 7
Sample Output 1
0 1 3 4
INF 0 2 3
INF INF 0 1
INF INF 7 0

Sample Input 2
4 6
0 1 1
0 2 -5
1 2 2
1 3 4
2 3 1
3 2 7
Sample Output 2
0 1 -5 -4
INF 0 2 3
INF INF 0 1
INF INF 7 0

Sample Input 3
4 6
0 1 1
0 2 5
1 2 2
1 3 4
2 3 1
3 2 -7
Sample Output 3
NEGATIVE CYCLE

这题先用Bellman-Ford算法判断负圈,再用Floyd-Warshall算法求任意两点间的最短路即可。

代码:

#include <iostream>
#include <algorithm>
#include <map>
#include <vector>
using namespace std;
typedef long long ll;
#define INF 2147483647

struct edge{
    int from,to,cost;
};

edge es[10000];

int d[110][110]; // d[i][j]表示点i到点j的最短路径 

int V,E; //点和边的数量 

//判断负圈 
bool find_negative_loop(){
    int s[110];
    fill(s,s+V,0);

    for(int i = 0;i < V; i++){
        for(int j = 0;j < E; j++){
            edge e = es[j];
            if(s[e.to] > s[e.from] + e.cost){
                s[e.to] = s[e.from] + e.cost;
                if(i == V-1) return false;
            }
        }
    }
    return true;
}

//任意两点间最短路径 
void warshall_floyd(){

    for(int k = 0;k < V; k++){
        for(int i = 0;i < V; i++){
            for(int j = 0;j < V; j++){
                if(d[i][k] != INF && d[k][j] != INF)
                    d[i][j] = min(d[i][j], d[i][k] + d[k][j]);
            }
        }
    }
}


int main(){


    cin >> V >> E;

    for(int i = 0;i < V; i++){
        for(int j = 0;j < V; j++){
            d[i][j] = INF;
        }
        d[i][i] = 0;
    }
    for(int i = 0;i < E; i++) cin >> es[i].from >> es[i].to >> es[i].cost,d[es[i].from][es[i].to] = es[i].cost;

    if(find_negative_loop()){
        warshall_floyd();
        for(int i = 0;i < V; i++){
            for(int j = 0;j < V; j++){
                if(j != 0) cout << " ";
                if(d[i][j] == INF) cout << "INF";
                else cout << d[i][j];
            }
            cout << endl;
        }
    }else{
        cout <<"NEGATIVE CYCLE" <<endl;
    }


    return 0;
} 
    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/zhangjiuding/article/details/78336035
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞