hdu 1690 Bus System 最短路(Dijkstra算法)

Bus System

                                                                     Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Problem Description Because of the huge population of China, public transportation is very important. Bus is an important transportation method in traditional public transportation system. And it’s still playing an important role even now.

The bus system of City X is quite strange. Unlike other city’s system, the cost of ticket is calculated based on the distance between the two stations. Here is a list which describes the relationship between the distance and the cost.

《hdu 1690 Bus System 最短路(Dijkstra算法)》

Your neighbor is a person who is a really miser. He asked you to help him to calculate the minimum cost between the two stations he listed. Can you solve this problem for him?

To simplify this problem, you can assume that all the stations are located on a straight line. We use x-coordinates to describe the stations’ positions.

 

Input The input consists of several test cases. There is a single number above all, the number of cases. There are no more than 20 cases.

Each case contains eight integers on the first line, which are L1, L2, L3, L4, C1, C2, C3, C4, each number is non-negative and not larger than 1,000,000,000. You can also assume that L1<=L2<=L3<=L4.

Two integers, n and m, are given next, representing the number of the stations and questions. Each of the next n lines contains one integer, representing the x-coordinate of the ith station. Each of the next m lines contains two integers, representing the start point and the destination.

In all of the questions, the start point will be different from the destination.

For each case,2<=N<=100,0<=M<=500, each x-coordinate is between -1,000,000,000 and 1,000,000,000, and no two x-coordinates will have the same value.

 

Output For each question, if the two stations are attainable, print the minimum cost between them. Otherwise, print “Station X and station Y are not attainable.” Use the format in the sample.

 

Sample Input

2 1 2 3 4 1 3 5 7 4 2 1 2 3 4 1 4 4 1 1 2 3 4 1 3 5 7 4 1 1 2 3 10 1 4  

Sample Output

Case 1: The minimum cost between station 1 and station 4 is 3. The minimum cost between station 4 and station 1 is 3. Case 2: Station 1 and station 4 are not attainable.   这道题本身并不难,WA两次之后才发现INF设的太小了,改成INF=1e18后,直接AC。

#include<stdio.h>
#include<string.h>
#define INF 1e18
const int N = 110;
__int64 x[510], w[N][N], d[N];

__int64 abs(__int64 x)
{
    return x >= 0 ? x : -x;
}

void Dijkstra(__int64 n, __int64 u)
{
    int vis[N];
    __int64 i;
    memset(vis, 0, sizeof(vis));
    for(i = 1; i <= n; i++)
        d[i] = INF;
    d[u] = 0;
    for(i = 1; i <= n; i++)
    {
        __int64 x = u, temp = INF;
        for(__int64 y = 1; y <= n; y++)
            if(!vis[y] && d[y] < temp)
                temp = d[x = y];
        if(temp == INF) break;
        vis[x] = 1;
        for(__int64 y = 1; y <= n; y++)
            if(d[y] > d[x] + w[x][y])
                d[y] = d[x] + w[x][y];
    }
}

int main()
{
    __int64 T, n, m, i, j, cas = 0;
    __int64 l[5], c[5];
    scanf("%I64d",&T);
    while(T--)
    {
        for(i = 1; i <= 4; i++)
            scanf("%I64d",&l[i]);
        for(i = 1; i <= 4; i++)
            scanf("%I64d",&c[i]);
        scanf("%I64d%I64d",&n,&m);
        for(i = 1; i <= n; i++)
            scanf("%I64d",&x[i]);
        for(i = 1; i <= n; i++)
            for(j = 1; j <= n; j++)
            {
                if(i == j)
                    w[i][j] = 0;
                else
                {
                    int temp = abs(x[i] - x[j]);
                    if(temp > 0 && temp <= l[1])
                        w[i][j] = w[j][i] = c[1];
                    else if(temp > l[1] && temp <= l[2])
                        w[i][j] = w[j][i] = c[2];
                    else if(temp > l[2] && temp <= l[3])
                        w[i][j] = w[j][i] = c[3];
                    else if(temp > l[3] && temp <= l[4])
                        w[i][j] = w[j][i] = c[4];
                    else if(temp > l[4])
                        w[i][j] = w[j][i] = INF;
                }
            }
        __int64 u, v;
        printf("Case %I64d:\n",++cas);
        for(i = 0; i < m; i++)
        {
            scanf("%I64d%I64d",&u, &v);
            Dijkstra(n, u);
            if(d[v] == INF)
                printf("Station %I64d and station %I64d are not attainable.\n", u, v);
            else
                printf("The minimum cost between station %I64d and station %I64d is %I64d.\n",u, v, d[v]);
        }
    }
    return 0;
}
    原文作者:Dijkstra算法
    原文地址: https://blog.csdn.net/LYHVOYAGE/article/details/19172807
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞