贪心算法:田忌赛马-HDU1052 & POJ2287 & ZOJ2397

 

Tian Ji — The Horse Racing

Time Limit: 5 Seconds      Memory Limit: 32768 KB

 

Here is a famous story in Chinese history.

“That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others.”

“Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser.”

“Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian’s. As a result, each time the king takes six hundred silver dollars from Tian.”

“Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match.”

“It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king’s regular, and his super beat the king’s plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?”

《贪心算法:田忌赛马-HDU1052 & POJ2287 & ZOJ2397》

Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian’s horses on one side, and the king’s horses on the other. Whenever one of Tian’s horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching…

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses — a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.

Input

The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian��s horses. Then the next n integers on the third line are the speeds of the king��s horses. The input ends with a line that has a single 0 after the last test case.

Output

For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

Sample Input

3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0

Sample Output

200
0
0

Source: Asia 2004, Shanghai (Mainland China)

 

/*

http://acm.hdu.edu.cn/showproblem.php?pid=1052
http://poj.org/problem?id=2287
http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=2397

 

 

 

题意,田忌赛马

思路:

 

 

 

  贪心策略,为了使田忌利益最大化,每一步尽可能地消耗齐王的马。

 

 1.若田忌最慢的马可以战胜齐王最慢的马,那么就让它战胜那匹慢马,胜场+1

 

 2.若田忌最慢的马不能战胜齐王最慢的马,那么它更加不能战胜其他的马,那就让它输给齐王最快马,

 

  败场加1。

 3.若田忌最慢的马与齐王最慢的马速度相等,分情况讨论:

 

  (1)如果此时田忌最快的马比齐王最快的马快,暂时先不用田忌的最慢马去消耗齐王的最快马了,先用田忌的

 

   最快马去vs齐王的最快马先赢一场,贪心算法(先赢一场再说)

  (2)如果田忌最快的马比齐王最快的马慢,那就用田忌的最慢马去消耗齐王的最快马。

  //结果:最糟也能1胜1负,如果直接对攻,则必为1负1平。

 

  和局不产生比分差(可以忽略)

 

*/

 

#include <iostream>
#include <algorithm>
using namespace std;

int TjHorse[1002];
int KingHorse[1002];
int n, win, lose;

void race()
{
	win = lose =0;
	int tBeg=0, tEnd=n-1;
	int kBeg=0,kEnd=n-1;
	for(; tBeg <= tEnd; )
	{
		if(TjHorse[tBeg] > KingHorse[kBeg])
		{
			++win;
			++tBeg;
			++kBeg;
		}
		else if(TjHorse[tBeg] < KingHorse[kBeg])
		{
			++lose;
			++tBeg;
			--kEnd;
		}
		else                    
		{
			if(TjHorse[tEnd] > KingHorse[kEnd])
			{
				++win;
				--tEnd;
				--kEnd;
			}
			else                     
			{
				if(TjHorse[tBeg] < KingHorse[kEnd])
					++lose;
				++tBeg;
				--kEnd;
			}
		}
	}
}
int main()
{
#ifndef ONLINE_JUDGE
	freopen("2.txt","r",stdin);
#endif
	while(scanf("%d",&n) != EOF && n)
	{
		for(int i=0; i < n; ++i)
			scanf("%d",&TjHorse[i]);
		for(int i=0; i < n; ++i)
			scanf("%d",&KingHorse[i]);
		sort(TjHorse,TjHorse+n);
		sort(KingHorse,KingHorse+n);
		race();
		printf("%d\n",200*(win-lose));
	}
	return 0;
}

 

 

 

 

    原文作者:贪心算法
    原文地址: https://blog.csdn.net/linraise/article/details/19175801
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞