Finding Nemo(图的广度遍历)

Finding Nemo

Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 9267 Accepted: 2192

Description

Nemo is a naughty boy. One day he went into the deep sea all by himself. Unfortunately, he became lost and couldn’t find his way home. Therefore, he sent a signal to his father, Marlin, to ask for help.

After checking the map, Marlin found that the sea is like a labyrinth with walls and doors. All the walls are parallel to the X-axis or to the Y-axis. The thickness of the walls are assumed to be zero.

All the doors are opened on the walls and have a length of 1. Marlin cannot go through a wall unless there is a door on the wall. Because going through a door is dangerous (there may be some virulent medusas near the doors), Marlin wants to go through as few doors as he could to find Nemo.

Figure-1 shows an example of the labyrinth and the path Marlin went through to find Nemo.

《Finding Nemo(图的广度遍历)》

We assume Marlin’s initial position is at (0, 0). Given the position of Nemo and the configuration of walls and doors, please write a program to calculate the minimum number of doors Marlin has to go through in order to reach Nemo.

Input

The input consists of several test cases. Each test case is started by two non-negative integers M and N. M represents the number of walls in the labyrinth and N represents the number of doors.

Then follow M lines, each containing four integers that describe a wall in the following format:

x y d t

(x, y) indicates the lower-left point of the wall, d is the direction of the wall — 0 means it’s parallel to the X-axis and 1 means that it’s parallel to the Y-axis, and t gives the length of the wall.

The coordinates of two ends of any wall will be in the range of [1,199].

Then there are N lines that give the description of the doors:

x y d

x, y, d have the same meaning as the walls. As the doors have fixed length of 1, t is omitted.

The last line of each case contains two positive float numbers:

f1 f2

(f1, f2) gives the position of Nemo. And it will not lie within any wall or door.

A test case of M = -1 and N = -1 indicates the end of input, and should not be processed.

Output

For each test case, in a separate line, please output the minimum number of doors Marlin has to go through in order to rescue his son. If he can’t reach Nemo, output -1.

Sample Input

8 9
1 1 1 3
2 1 1 3
3 1 1 3
4 1 1 3
1 1 0 3
1 2 0 3
1 3 0 3
1 4 0 3
2 1 1
2 2 1
2 3 1
3 1 1
3 2 1
3 3 1
1 2 0
3 3 0
4 3 1
1.5 1.5
4 0
1 1 0 1
1 1 1 1
2 1 1 1
1 2 0 1
1.5 1.7
-1 -1

Sample Output

5
-1

Source

题目大意:有一个迷宫,在迷宫中有墙与门
有m道墙,每一道墙表示为(x,y,d,t)
x,y表示墙的起始坐标
d为0即向右t个单位,都是墙
d为1即向上t个单位,都是墙
有n道门,每一道门表示为(x,y,d)
x,y表示门的起始坐标
d为0即向右一个单位表示门
d为1即向上一个单位表示门
再给出你起点的位置(f1,f2),并保证这个点的位置不会再墙或者门中,为起点到(0,0)最少要穿过多少条门

注意:在迷宫中不只有门和墙,还有空地

空地为0,墙为INF,门为1

首先全赋值为墙
然后根据输入来赋值
这样就便于搜索了
这里要注意的是要全部搜索完,因为要穿过最少的门,用优先队列搞定
还有当在迷宫外面时,直接输出0

因为迷宫可能在[1,199]但是目标人物所在坐标可能超出这个范围

#include <iostream>
#include <cstdlib>
#include <queue>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define inf 0x3f3f3f3f
using namespace std;
int h[300][300],l[300][300],dis[300][300],maxx,maxy;
int sx,sy;
struct node
{
   int x,y,door;
   bool operator <(const node&a)const//优先队列
   {
      return a.door<door;
   }
};
void bfs()
{

   priority_queue<node>q;
   while(!q.empty())
    q.pop();
   for(int i=0;i<=maxx;i++)
   {
       for(int j=0;j<=maxy;j++)
       {
           dis[i][j]=inf;//全赋值为墙
       }
   }
   struct node c;
   dis[0][0]=0;//从0,0点出发,穿过墙的个数
   c.x=0;
   c.y=0;
   c.door=0;//穿过墙的个数
   q.push(c);
   while(!q.empty())
   {
       c=q.top();
       q.pop();
       int x=c.x,y=c.y;
       if(x==sx&&y==sy)
        return ;
       if(x+1<=maxx&&dis[x+1][y]>dis[x][y]+l[x+1][y])//向右,开始全赋值为墙,所以只要是无穷大就没访问过
       {
          dis[x+1][y]=dis[x][y]+l[x+1][y];//门为1,所以加起来小于无穷大
          c.y=y;
          c.door=dis[x+1][y];
          c.x=x+1;
          q.push(c);
       }
       if(y+1<=maxy&&dis[x][y+1]>dis[x][y]+h[x][y+1])
       {
          dis[x][y+1]=dis[x][y]+h[x][y+1];
          c.x=x;
          c.door=dis[x][y+1];
          c.y=y+1;
          q.push(c);
       }
       if(x-1>=0&&dis[x-1][y]>dis[x][y]+l[x][y])
       {
          dis[x-1][y]=dis[x][y]+l[x][y];

          c.y=y;
          c.door=dis[x-1][y];
          c.x=x-1;
          q.push(c);
       }
       if(y-1>=0&&dis[x][y-1]>dis[x][y]+h[x][y])
       {
          dis[x][y-1]=dis[x][y]+h[x][y];

          c.x=x;
          c.door=dis[x][y-1];
          c.y=y-1;
          q.push(c);
       }
   }
   dis[sx][sy]=-1;
}
int main()
{
    int n,m,x,y,d,t;
    double fx,fy;
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        if(n==-1&&m==-1)
            break;
        maxx=-1;
        maxy=-1;
        memset(h,0,sizeof(h));
        memset(l,0,sizeof(l));
        while(m--)
        {

            scanf("%d%d%d%d",&x,&y,&d,&t);
            if(d==0)
            {
               for(int i=0;i<t;i++)
               {
                  h[x+i][y]=inf;//墙
               }
               maxx=max(maxx,x+t);
               maxy=max(maxy,y);//找出墙的最大范围
            }
            else
            {
               for(int i=0;i<t;i++)
               {
                   l[x][y+i]=inf;
               }
               maxx=max(maxx,x);
               maxy=max(maxy,y+t);
            }

        }
        while(n--)
        {
           scanf("%d%d%d",&x,&y,&d);
           if(d==0)
            h[x][y]=1;//门不会超过墙
           else
            l[x][y]=1;//后面每有一个墙就加一
        }

        scanf("%lf%lf",&fx,&fy);
        sx=(int)fx;
        sy=(int)fy;
        if(fx>maxx||fy>maxy)//超出范围
        {
           printf("0\n");
           continue;
        }
        bfs();
        printf("%d\n",dis[sx][sy]);

    }
    return 0;
}
    原文作者:数据结构之图
    原文地址: https://blog.csdn.net/jinzk123/article/details/52860419
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞