错误的类文件:… 类文件具有错误的版本 52.0,应为 50.0

出现问题:

今天在pom.xml中引入了最新版本guava工具包,编译时报了如下错误:

[ERROR] E:\workspace\report\src\main\java\indi\johnny\report\template\excel\ExcelXSSFStyle.java:[16,-1] 无法访问 com.google.common.base.Strings
错误的类文件: com\google\common\base\Strings.class(com\google\common\base:Strings.class)
类文件具有错误的版本 52.0,应为 50.0

如图:

《错误的类文件:… 类文件具有错误的版本 52.0,应为 50.0》

图1

概念引进:

      major.minor 版本号:每个版本的 JDK 编译器编译出的 class 文件中都带有一个版本号。

      上面截图中出现的52.0 50.0 就是我们所说的major版本号。

 

问题排查:

将出现问题的guava-21.0.jar 通过[ jar –xvf  guava-21.0.jar ]解压后,进入目录,找到报出异常的类”Strings”

《错误的类文件:… 类文件具有错误的版本 52.0,应为 50.0》

图2

通过找到报出异常的类”Strings” ,使用 命令:[  javap -verbose Strings ]  ,能显示出类的 major.minor 版本,major版本确实为52。

《错误的类文件:… 类文件具有错误的版本 52.0,应为 50.0》

图3

解决方案:

降低guava的版本,如下图所示,将版本21.0换成19.0:

《错误的类文件:… 类文件具有错误的版本 52.0,应为 50.0》

图4

再次编译项目,则编译成功。

解压 guava-19.0.jar后,找到报出异常的类”Strings” ,使用 命令:[  javap -verbose Strings ]  ,能显示出类的 major.minor 版本,为50。

《错误的类文件:… 类文件具有错误的版本 52.0,应为 50.0》

图5

jdk版本与major版本对应的关系如下,参考博客:http://smilejay.com/2014/02/java-unsupported-major-minor-version-51-0/

《错误的类文件:… 类文件具有错误的版本 52.0,应为 50.0》

图6

我本地的jdk版本为1.6(等同6.0),对应的major版本为50,所以异常提示的信息为 “应为 50.0”

查看guava-21.0.jar解压后目录META-INF下的文件MANIFEST.MF,如图所示,jdk编译版本为1.8:

《错误的类文件:… 类文件具有错误的版本 52.0,应为 50.0》

图7

但是查看guava-19.0.jar解压后目录META-INF下的文件MANIFEST.MF,如图所示,jdk编译版本不是1.6,而是1.7:

《错误的类文件:… 类文件具有错误的版本 52.0,应为 50.0》

图8

个人理解:class文件加载至jvm并不是完全按照图6一 一对应的关系,而是按照major.minor版本号范围来加载至JVM,超出范围则要出错。

本地1.6的环境能够识别并运行1.7编译的guava-19.0.jar包,是因为guava-19.0.jar中的”Strings”类的major版本号为50。

参考博客:http://sheng.iteye.com/blog/690035

 

结论:加载至jvm中的class文件,class文件的major版本号必须等于或小于当前jvm环境要求的最大major版本号。

通俗讲:假设Student.class的major版本号为50,既可以放在1.6的jvm中运行,也可以放在1.8的jvm中运行。若Student.class的major版本号为52,则只能在1.8或更高版本的jvm中运行。

 

欢迎拍砖!

    原文作者:只打小松鼠
    原文地址: https://www.cnblogs.com/xxyfhjl/p/6363264.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞

发表评论

电子邮件地址不会被公开。 必填项已用*标注