python下安装Scikit-learn

安装SK-Learn需要依赖的Python安装包有:

Python (>= 2.6),

NumPy (>= 1.3),

SciPy (>= 0.7),

下载python的各种包的地址:http://www.lfd.uci.edu/~gohlke/pythonlibs/

 在下载各种包的时候要注意版本的选择:

①查看本地安装的python的版本,使用如下命令

python -V

《python下安装Scikit-learn》

②下载软件

我的安装的python是32位,因此我需要下载,并按如下顺序安装

numpy-1.12.1+mkl-cp35-cp35m-win32.whl

matplotlib-1.5.3-cp35-cp35m-win32.whl

scipy-0.19.0-cp35-cp35m-win32.whl

注意cp后边一定要和我的python版本一样,否则会报错的。

③安装

安装.whl文件和用pip安装其他文件是一样的,

python -m pip3 install 文件名

例如:python -m pip3 install numpy-1.12.1+mkl-cp35-cp35m-win32.whl

④测试

http://scikit-learn.org/stable/auto_examples/linear_model/plot_ols.html#example-linear-model-plot-ols-py,下载源码运行,得到结果:

《python下安装Scikit-learn》

则说明安装成功。

    原文作者:nolonely
    原文地址: http://www.cnblogs.com/nolonely/p/6897296.html
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞

发表评论

电子邮件地址不会被公开。 必填项已用*标注