正确安装python量化交易常用包talib

首先你要明确你的系统版本,win32系统还是Linux,X86还是X64;
如果你的系统是x86平台,在安装了anaconda 的基础上,可以直接使用pip安装,命令如下:

pip install talib

如果你的系统是x64平台,直接使用上述命令安装汇报错如下:

《正确安装python量化交易常用包talib》 20180921091804221.png

原因在于python pip源中TA-Lib是32位的,不能安装在X64平台上,从TA-Lib的官网http://ta-lib.org下载的安装包其实也是32位的,如果你的系统平台是64位的,也无法正确安装。

正确的方法是下载64位的安装包,本地安装,64位安装包官网并没有提供,我们必须自行下载。

下载推荐使用加州大学的python扩展库,地址:https://www.lfd.uci.edu/~gohlke/pythonlibs/

对应TA_Lib包列表如下:

《正确安装python量化交易常用包talib》 20180921093338134.png

从上面下载的这个:

TA_Lib-0.4.17-cp27-cp27m-win_amd64.whl
然后在windows的cmd里面输入命令:

pip install TA_Lib-0.4.17-cp27-cp27m-win_amd64.whl

把TA_Lib-0.4.17-cp27-cp27m-win_amd64.whl放在C:\Windows\system32>文件夹下面
C:\Windows\system32>pip install TA_Lib-0.4.10-cp27-cp27m-win_amd64.whl
Processing c:\windows\system32\ta_lib-0.4.10-cp27-cp27m-win_amd64.whl
Installing collected packages: TA-Lib
Successfully installed TA-Lib-0.4.10

《正确安装python量化交易常用包talib》 20180921093711774.png

注意事项:本人安装的python环境是2.7版的,所以下载TA_Lib-0.4.17-cp27-cp27m-win_amd64.whl这个64位版本,如果你使用的python3.5或python3.7,请下载对应版本,否则安装不会成功。

python3.5的64位平台:TA_Lib-0.4.9-cp35-none-win_amd64.whl

python3.7的64位平台:TA_Lib-0.4.9-cp37-none-win_amd64.whl

安装TA_Lib库的坑让我好找!仅此记录详细过程,与人共享,防止有人和我一样走弯路。

作者:老野_
来源:CSDN
原文:https://blog.csdn.net/feixuedongji/article/details/82796381

    原文作者:二划儿
    原文地址: https://www.jianshu.com/p/d17977567e6a
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞

发表评论

电子邮件地址不会被公开。 必填项已用*标注